~bohwaz/blog/

Avec de vrais morceaux de 2.0 !

Duke Nukem 3D

Pour installer Duke Nukem 3D sous Linux , il faut d'abord les dépendances de compilation de Eduke32 :

$ sudo apt-get install libsdl-mixer1.2-dev nasm g++ libgtk2.0-dev timidity

Maintenant il nous faut le fichier de données, téléchargeable ici : duke3d.grp

Une fois téléchargé il faut le décompresser et le mettre dans le bon répertoire :

$ tar xzvf duke3d.grp.tar.gz
$ mkdir ~/.eduke32
$ mv duke3d.grp ~/.eduke32/

Ensuite on télécharge et compile EDuke32 :

$ cd /tmp
$ wget http://wiki.eduke32.com/stuff/eduke32_src_20080709.zip
$ unzip eduke32_src_*.zip
$ rm eduke32_src_*.zip
$ cd eduke32*/eduke32
$ make

A partir de là vous pouvez lancer ./eduke32 dans le répertoire de EDuke32 pour jouer à la version classique, mais si vous voulez des trucs plus jolis il est possible de télécharger le High Resolution Pack ici : HRP. Ensuite faites un coup de unzip, et déplacez le dossier "autoload" et son contenu dans ~/.eduke32/

Voilà !

Écrire un commentaire
(facultatif)
(facultatif)
(obligatoire)
       __      _ _   
 _ __ /_/  ___(_) |_ 
| '__/ _ \/ __| | __|
| | |  __/ (__| | |_ 
|_|  \___|\___|_|\__|
                     
(obligatoire)

Les adresses internet seront converties automatiquement.
Tags autorisés : <blockquote> <cite> <pre> <code> <var> <strong> <em> <del> <ins> <kbd> <samp> <abbr>